Wave Device for Voice Modem Drivers Download

Download the latest version of Wave Device for Voice Modem drivers according to your computer's operating system. All downloads available on this website have been scanned by the latest anti-virus software and are guaranteed to be virus and malware-free.

Browse the list of top Wave Device for Voice Modem drivers below to find the driver that meets your specifications. To see more matches from our driver database, use our customized search engine to search for all Wave Device for Voice Modem drivers. Let us know if you do not find the driver you need.

To download, select the best match for your device and then click the Download button. Need help? You can get help and discuss drivers on our free driver forum. If all else fails, you can request the driver and we will find it for you.

Search All Wave Device for Voice Modem Drivers

Download Popular Wave Device for Voice Modem Drivers

Wave Device for Voice Modem Driver Update Utility

Supported OS: Windows 10, Windows 8.1, Windows 7, Windows Vista, Windows XP
File Version: Version 5.0.1171
File Size: 1.2 MB
Overall Rating:
Download >>

MD-2781 / MC2780-7E series Driver


Supported OS: Win 95
File Size: 5.9 MB
File Name:

Overall Rating: (21 ratings, 45 reviews)
Download >>


Submitted Sep 5, 2000 by Berumn (DG Member):
"This modem/sound card has K56FLEX technologies and with the IBM_MWave_MD-2781_56kupgrade.exe your 33.6Kbps becomes FLEX56Kbps VOD.And with the IBM_MWave_MD-2781_56k (win98update).exe the hardware runs with Win98.Look for them, I uploaded them on DriverGuide as well."

MDSP 2780/1 Driver


Supported OS: Win 98, Win 95
File Size: 3.4 MB
File Name:

Overall Rating: (9 ratings, 20 reviews)
Download >>


Submitted Mar 4, 2001 by Jeffery Mullins (DG Member):
"This is a V.34 upgrade of the 33.6 Mwave Modem. Unzip this and you will have 4 files. Go to a Dos Prompt and Format 4 1.44Mg disks. Then go to the directory when you downloaded the file and type filename -d a It then will copy to the floppy disks. You must not have any previous drivers loaded for these ..."
server: web5, load: 1.58